Priyanshu Pandey

EIGRP Configuration

Enhanced Interior Gateway Routing Protocol (EIGRP) is a dynamic network-layer protocol with protocol number 88, initially a Cisco proprietary system but transitioning toward an open standard.

EIGRP facilitates classless routing, VLSM, route summarization, and efficient load balancing. Unlike earlier protocols like IGRP or BGP, EIGRP enhances data exchange efficiency among routers. Born from Cisco’s 1990s initiative to address protocol limitations, EIGRP was devised for scalable routing, especially when linking vast teleworker networks. Its creation eliminated manual routing table adjustments, streamlining expansive network operations.

Configuring EIGRP on Routers

There are two steps involved in the EIGRP configuration.

  1. Enable EIGRP.
  2. Provide the required details to the EIGRP.

Step 1:- Enable EIGRP

We can enable EIGRP by using the following command.

“c Router(config)# router eigrp X

EIGRP is enabled with **AS** (Autonomous System) number `X` using the first command. Since we used the AS number `X`, this router will only exchange routing information with other routers that are part of the AS number `X`.  


**Step 2:- Provide the required details to the EIGRP**

```c
Router(config-router)# network X.X.X.X

Where X.X.X.X is the network id of a network directly connected to the router. This command should be entered for each network that is directly connected to the router. You can, however, insert the supernet of a set of subnets in a single line. When you do this, the router will automatically recognize the subnets.

This command enables EIGRP on specific interfaces and specifies which networks will be advertised. The network command accepts a classful network number as an argument by default.

To understand these steps more clearly, let’s take an example of the following network.

The network shown above has just two routers. A directly connected subnet on each router needs to be broadcast using EIGRP. The EIGRP configuration for R1 and R2 is as follows:

For Router R1

R1(config)#router eigrp 1   // This step enables EIGRP with AS number 1 on router R1    
R1(config-router)#network 10.0.0.0   // This step adds the network to the router.
R1(config-router)#network 172.16.0.0
R1(config-router)#

For Router R2

R2(config)#router eigrp 1   // This step enables EIGRP with AS number 1 on router R2.  
R2(config-router)#network 192.168.0.0   // This step adds the network to the router.
R2(config-router)#network 172.16.0.0
R2(config-router)#

Enabling EIGRP

The following command is used in global configuration mode to enable EIGRP.

Router(config)# router eigrp AS_NUMBER

The above command activates EIGRP and places us in EIGRP configuration mode. It simply requires one parameter, the AS (Autonomous System) number. EIGRP creates a group of routers that can share routing information using an AS number. As an AS number, you can select any number between 1 and 65535. After you’ve chosen a number, you must use it on all routers. Two routers from distinct ASs will not share routing information.

Customizing EIGRP

The network is added to the EIGRP operation using the following command in EIGRP configuration mode.

Router(config-router)# network network_address [WILDCARD_MASK]

The above command requires two parameters:

  1. Network address:- The network address is the network ID of the subnet you want to include in the EIGRP operation.
  2. Network wildcard mask:- The wildcard mask specifies the range of addresses to include in the operation. Subtract the subnet mask from 255.255.255.255 to obtain the wildcard mask. This calculation is illustrated in the table below.
Subtract fromSubnet mask of a networkCalculated Wildcard mask
255.255.255.255255.255.0.00.0.255.255
255.255.255.255255.255.255.2520.0.0.3
255.255.255.255255.128.0.00.127.255.255
255.255.255.255255.0.0.00.255.255.255

This command will only add one network at a time. You can use the same command repeatedly to add multiple networks. For example, if you wish to add three networks, you must run this command three times.

EIGRP Configuration Packet Tracker Example

Consider the following example.

Let’s discuss the commands used to configure and enable EIGRP on Router 0:

  1. EIGRP is enabled with AS (Autonomous System) number 20 using the first command. This router will only exchange routing information with other routers that are part of the AS number 20 since we used the AS number 20.Router(config)#router eigrp 20
  2. The network 10.0.0.0 is added to the EIGRP operation by the second command. Network 10.0.0.0/8’s subnet mask is 255.0.0.0. The wildcard mask for this subnet mask was calculated by deducting it from 255.255.255.255.Router(config-router)#network 10.0.0.0 0.0.0.255 EIGRP verifies the IP configuration of every interface when we add a network and enables EIGRP operation on the corresponding interfaces. Since the interface F0/0’s IP configuration is configured to be a part of the network 10.0.0.0/8, EIGRP is enabled on the interface F0/0.
  3. The third command adds the network 255.255.255.252/30 (192.168.1.244) to the EIGRP operation. Since this network is set up on Serial interface S0/0/0, EIGRP permits EIGRP activity on that interface.Router(config-router)#network 192.168.1.244 0.0.0.3
  4. The network 255.255.255.252/30 (192.168.1.0) is added to the EIGRP operation with the fourth command. The F0/1 interface is set up for this network. As a result, EIGRP allows EIGRP to operate on the F0/1 interface.Router(config-router)#network 192.168.1.0 0.0.0.3

Similarly, we can configure all routers using these four commands.

Router 1:

Router(config)#router eigrp 20
Router(config-router)#network 192.168.1.244 0.0.0.3
Router(config-router)#network 192.168.1.248 0.0.0.3
Router(config-router)#

Router 2:

Router(config)#router eigrp 20
Router(config-router)#network 192.168.1.248 0.0.0.3
Router(config-router)#network 192.168.1.252 0.0.0.3
Router(config-router)#

Router 3:

Router(config)#router eigrp 20
Router(config-router)#network 192.168.1.8 0.0.0.3
Router(config-router)#network 192.168.1.4 0.0.0.3
Router(config-router)#

Router 4:

Router(config)#router eigrp 20
Router(config-router)#network 192.168.1.4 0.0.0.3
Router(config-router)#network 192.168.1.0 0.0.0.3
Router(config-router)#

Router 5:

Router(config)#router eigrp 20
Router(config-router)#network 20.0.0.0 0.255.255.255
Router(config-router)#network 192.168.1.252 0.0.0.3
Router(config-router)#network 192.168.1.8 0.0.0.3
Router(config-router)#

Verifying EIGRP Configuration

Generally, there are two ways to verify EIGRP configuration:

  1. By testing end-to-end connectivity
  2. By listing EIGRP routes on the router

By Testing End-To-End Connectivity

  • Using the ping command, we can verify that two devices are connected. This command sends test data packets to the target device, and the response is monitored. If the destination device responds, it lists the responses on the console. A successful response confirms proper connectivity between the source and the destination.
  • The tracert command is another option. This command likewise delivers phoney data packets to the destination device, but instead of watching for a response, it tracks the route the data packets take to get there.

By Listing EIGRP Routes on the Router

  • To view all routes added to the routing table using EIGRP, run the “show ip route eigrp” command on the router.
  • If there are many routes to the same destination, EIGRP inserts the route with the lowest metric value into the routing table. We can use the “show ip eigrp topology” command to see all available routes for each destination.
  • If there is a loop in a network, EIGRP automatically removes the loop. It just picks one of the paths that make up a loop to delete it. It compares the metrics of each route to choose the one with the lowest metric.
  • EIGRP discovers all network routes. However, it does not include the paths that form a loop. They are used as backup routes. If the primary route fails, the system automatically changes to the backup route.

Conclusion

  • The Enhanced Interior Gateway Routing Protocol (EIGRP) is a network-layer dynamic routing protocol that operates on protocol number 88.
  • EIGRP offers classless routing, VLSM, route summarization, load balancing, and various additional capabilities.
  • Compared to prior network protocols like Interior Gateway Routing Protocol (IGRP) or Border Gateway Protocol (BGP), Enhanced Interior Gateway Routing Protocol (EIGRP) allows routers to exchange data more efficiently.
  • To enable EIGRP with AS number X, use the following command:Router(config)# router eigrp X
  • After enabling EIGRP with AS number X, use the following command to enable EIGRP on specific interfaces and specifies which networks will be advertised.Router (config-router)# network X.X.X.X
  • The network is added to the EIGRP operation using the following command in EIGRP configuration mode.Router(config-router)# network network_address [WILDCARD_MASK]
  • To obtain the wildcard mask subtract the subnet mask from 255.255.255.255.

Author